TSX IM on 06 accord [Archive] - K-Series Forums

View Full Version : TSX IM on 06 accord



H1gh0ct4n3
12-06-2007, 03:15 PM
Ok so im new hear and iv been hearing alot about the TSX IM upgrade and its great bang for the buck performance. But im a little iffy on buying it because im sure you need the mounts and stuff to... If anyone knows a good place to get the IM and the neccisary stuff in one good purchase help a fellow accord driver out lol.
Iv looked all over on ebay and other stuff but cant find nothing but gaskets
Also anyone else who has done this tell me what you think overall.

The Pope
12-07-2007, 03:40 PM
Here's a link to Driveaccord.net where the TSX IM is discussed. There's a good amount of info there.

http://www.driveaccord.net/forums/showthread.php?t=899 9

I have the TSX IM on my 2k6 Accord and I love it!:bigTup:

H1gh0ct4n3
12-08-2007, 02:51 PM
yea i was reading up that page before and theres tons of info about it and the gains and all but i couldn't find a solid link of a seller.
plus i registered there to but there approval process is weired...
thanks for the help and also how easy is the install? b/c from what i hear its EZ mode only takes like 30 min or so?

The Pope
12-09-2007, 07:27 PM
It's an easy mod. & 30 min. sounds about right. As far as where to purchase, the place (web site) no longer is valid, so a Google search for "Acura Parts".

I found these sites:

www.acuraparts247.co m
www.acuraparts.com
www.acurapartspeople .com

Good luck in your search!

H1gh0ct4n3
12-11-2007, 02:19 PM
It's an easy mod. & 30 min. sounds about right. As far as where to purchase, the place (web site) no longer is valid, so a Google search for "Acura Parts".

I found these sites:

www.acuraparts247.co m
www.acuraparts.com
www.acurapartspeople .com

Good luck in your search!
thanks alot!
but those first 2 sites dont work lol.
this is definitely gonna be my next upgrade so i cant wait im already saving.

The Pope
12-12-2007, 04:54 AM
Here's another site I just found.

http://www.acuraoemparts.co m/delray/jsp/home.jsp

H1gh0ct4n3
12-13-2007, 12:13 PM
sweet thanks i found it on the 3rd site you linked for the cheapest w00t.

The Pope
12-13-2007, 02:27 PM
Good deal! :bigTup:

turBeau
01-29-2008, 01:39 PM
Ordered mine from the last one the "The Pope" suggested. Its on back order and won't be shipped until the 30th of this month. Order now if you want it anytime soon cause it'll take awhile.

07accord540
04-17-2008, 03:03 PM
i recently installed a tsx im on my 07 accord. the install went fine but now i am having some idle issues. i thought it was a vacuum leak but all connections seem tight. i plugged the small hole on the back of the im and torqued down the im and throttle body so there shouldnt be any leak. anyone have any suggestions?

The Pope
04-18-2008, 05:33 AM
It might just be the ECU learning the new airflow characteristics.

Or

Check the sensor that you had to swap off of the old IM to the new IM which is located on the IM near to where the throttle body attached to the IM. I believe that it (sensor) should have an o-ring on it to seal off any vacuum leeks. If it is suppose to have an o-ring, it might have come off when you removed it from the old IM and it may even still be in the hole of the old IM.
Also check the connector which plugs to this sensor. May have bent a pin or something which is causing the ECU to not be able to obtain readings from it.

You may know this already, but another good way to find a vacuum leek is to spray carb cleaner (while the engine is running) on areas where there might be a leek. If the idle changes, that's where the leek is. If there's no change in the idle, there is most likely something else that's not right.

K24power07
09-17-2008, 08:25 AM
this may be a stupid question, but wat advantages will u get if u put a tsx im in ur 7th gen accord...

07accord540
09-17-2008, 10:13 AM
more power. the stock manifold in restrictive. i noticed more of a power increase from the tsx im than from the cai.

K24power07
09-17-2008, 08:12 PM
thankzzzzz

1slowk24
10-15-2008, 11:18 PM
Could be an issue with the gasket (either tb or manifold gasket)